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1. About the P5 Archive App 
The P5 Archive App integrates Archiware’s P5 Archive functionality into the OS X Finder. Using the 
P5 Archive App, you can now archive and restore files and folders from your Desktop, no matter if 
items reside on your local machine or in a central storage location. 

It’s your perfect companion if you want to make room on your primary storage by moving single 
files, complete projects or folder structures to Archiware’s P5 Archive solution. 

The beauty of the App lies in the way it lets the Finder deal with archived files. Once a file has 
been archived, the P5 Archive App deletes the file from its original location and places a very small 
file with the same filename and the extension “.p5a” at the original location. When you double-click 
on this file, the App presents both a preview and item metadata to you, so that you can make an 
informed decision on whether you want to restore an item. 

With the help of the P5 Archive App, the Finder presents you with a common view on both online 
and offline data, so you can always find your files in their original location, no matter if they are still 
on your primary disk or have been archived offline. 
In addition, the P5 Archive App understands Final Cut Pro X projects including external media, 
which allows you to archive and restore complete Final Cut Pro X projects including all media used 
within a project. 

Version 1.1 of the P5 Archive App adds a Share Destination setting to Final Cut Pro X, which 
allows archiving from within Final Cut Pro. When you archive your Final Cut Pro X library from 
within Final Cut Pro, clip metadata and keywords will be copied to Archiware P5 Archive. 

This enables you to search for more comprehensive metadata inside P5 Archive. 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2. Quick Start 

2.1. Requirements 
Before you install the P5 Archive App on your P5 server or on a client, please make sure your P5 
Server runs P5 5.3.3 or newer and you have installed P5 5.3.3 or newer on the P5 Archive App 
client, too. 
The P5 Archive App runs on OS X 10.9 or newer.  

2.2. Installation and Setup 
Please download the latest OS X P5 installer image from the Archiware website, and open the 
installer image.

!  
If you open the PDF file“Download P5 Archive App”, you will find a link, from where you can 
download the P5 Archive App installer image to your local disk. The image includes the P5 Archive 
App as well as the manual. 

Drag and drop the P5 Archive App to your Applications folders and then double-click on the P5 
Archive App icon in your Applications folder. As the App has not been configured yet, it welcomes 
you with its Preferences window. 
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!  

You need to enter the IP address or DNS name of your P5 server, the server port, which you use to 
invoke the P5 admin web interface, as well as a user name and password to access your P5 
server. Then choose an archive plan which you are going to use to store your data. 

Please make sure your Archive plan doesn't delete files or folders. It is highly recommended to 
make your Archive plan incremental to prevent generating duplicates, but this is not enforced by 
the P5 Archive App. 
You also need to enter a client name. This means you have to set up your P5 Archive App machine 
as a client in the Client settings on the P5 server and enter the name you set up on the server as 
well as in the P5 Archive App preferences. 
IMPORTANT NOTE: If your server accesses a central storage using the same absolute path like 
your P5 Archive App client, you can enter “localhost” as the client name in the P5 Archive App 
settings. In this case the server reads and writes your files directly on your central storage without 
passing them through your client. This is a great feature if your server connects to your central 
SAN storage via 8 or 16Gb Fibre Channel connection, e.g., as this setup speeds up your archive 
and restore processes dramatically. Please note, that in this case you can’t archive and restore 
files from your client’s local disk, though. 
When you save your settings, the Preferences window will check if it can access the server and 
will display the status message on the top of the window. 
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In addition, you have three settings managing your archive workflows: 
• “Create p5a files”. This is turned on by default and means that after a file has successfully 

been archived, the P5 Archive App replaces the original file with a very small file using the 
original filename plus the suffix “.p5a”. You can then double-click on this file to display the 
original file's preview and metadata, and can optionally restore an item. 
If you don't activate this setting, the P5 Archive App deletes the file after archiving. It will 
always preserve folders. 
IMPORTANT NOTE: If you want to restore files from the Finder, the P5 Archive App 
requires the generation of p5a files. 

• “Archive library files generated by FCPX”. This is turned off by default. When archiving a 
Final Cut Pro X library, the P5 Archive App understands that Final Cut Pro X generates lots 
of temporary data like thumbnails and waveforms, which can be generated on the fly when 
you open a project. To prevent flooding your archive with lots of unnecessary data, by 
default the P5 Archive App doesn't archive these files. Mark this option if you want to 
preserve these files. 

• “Add metadata during archive process”. Turned off by default. Once activated, whenever 
you trigger an archive process, the P5 Archive App allows you to enter metadata for your 
archived items. If turned off, you locate your files by navigating through the filesystem only, 
as no additional metadata are available. 

Once you have saved your settings you can close the Preferences window. 

2.3. Keyboard Shortcuts 
If you navigate through your filesystem using your keyboard, you can set up keyboard shortcuts to 
trigger archiving and restoring. 
Open your System Preferences application and navigate to Keyboard -> Shortcuts -> Services: 

!  
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Select “Archive to P5” and add a shortcut of choice. Do the same for “Restore from P5”. 

Now you can trigger archiving and restoring items from the Finder using keyboard shortcuts. 

2.3. Usage 
The main window of the P5 Archive App is the job monitoring window. 

!  

At the top, it shows you status messages. In the table below it lists the jobs started from your 
machine as well as jobs started from other machines as long as they are active or scheduled, so 
that you always know what's going on on your server. 
On the left, you see the job status, then the owner (“me” or “other”), the type (“archive” or “restore”) 
as well as the job ID. 

When you select a job, you can cancel it, list all items that belong to a job, or get a report for a 
completed job. 

To start a job, open a Finder window and right-click on any file or folder. “Archive to P5” will trigger 
an archive process, and after a few seconds the job appears in the P5 Archive App job monitor 
window. 
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!  
After the original file has been deleted, a p5a file will be created in its place. When you double-click 
on it, you see a preview window, which allows you to read or modify the item's metadata, restore 
the item and – if it's a video file – to click on the arrow symbol to open a video preview in your 
QuickTime Player. 

!  

The metadata schema displayed in this window is the one you have configured in your P5 admin 
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web interface at Archive - Manage Indexes - Fields…. 

!  

This opens the panel where you set up your metadata schema.
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!  

When you close the preview window, you can restore a file or a folder by selecting it in the Finder, 
right-clicking on it and selecting “Restore from P5”. This will trigger a restore and replace the p5a 
files with the original files. 

In the job monitor you can select a job and hit “List items” to see which items belong to a job. 

!  
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If the job has completed, click “Get report” to see a job report. 

!  

2.4. Final Cut Pro X Support when archiving within the Finder 
When you archive a folder structure, the P5 Archive App always scans it for Final Cut Pro X 
libraries. Once it finds one or more FCPX libraries, it checks if the library uses any external media 
which are not part of your current archive selection. 

If it finds external media, these will be archived, too, yet, they will not be removed from your 
filesystem automatically, as the P5 Archive App doesn't know if any other projects still use these 
external media. 
If you want to remove external media and create p5a files for them, too, please select them and 
trigger a second archive process. 

If your archive plan is an incremental archive plan, this will not generate any duplicates on tape but 
will simply generate p5a files. 

Once you restore a Final Cut Pro X library, the P5 Archive App will make sure that all external 
media will be restored, too, so that you can start working on your project. 

This allows moving a project from one machine to another. 
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2.5. Archiving from within Final Cut Pro X 
This feature requires Final Cut Pro X 10.1.4 or later. 
To allow Final Cut Pro X archiving to P5 choose File -> Share -> Add Destination… from the menu 
bar. This opens the destinations settings panel. 

!  
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Now drag the “Export File” template to the Destinations column on the left: 

!  
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Rename the Destination to “P5 Archive App” and make sure that your copy of the P5 Archive App 
is selected in the “Open with” dropdown menu: 

!  

Now you can close the Destinations panel. 
To archive a library, open a project or clip inside FCPX and choose File -> Share -> P5 Archive 
App… This opens a panel where you can edit your project’s metadata and modify your export 
settings. You can ignore the settings panel, as the P5 Archive App does not export a media file 
from FCPX but extracts metadata from FCPX instead and therefore ignores the settings. 

Click on “Next…” to proceed. This triggers an archive process which behaves exactly like the 
archive process from within the Finder, with the only difference, that the files inside P5 Archive will 
carry all the metadata you transfer from Final Cut Pro X. 
Important Note: During the export the “Extended” metadata view will be used. Please make sure 
that either you only work in the Extended metadata view inside FCPX or that all fields you use in 
your metadata view are enabled in the Extended metadata view, too. 
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2.6.Preparing your Archive Index 
When you archive files and folders, P5 Archive will only store metadata for which you set up 
metadata fields inside the Archive index of your archive plan. To create metadata fields inside the 
P5 Archive index, please proceed like this: 

• Open the P5 web interface and navigate to Archive -> Archive Plan. Double-click on the archive 
plan you use with the P5 Archive App. 

• In the archive plan settings you find the “General Setup” section, in which the value fore “Target 
Index” can be found. By default this is “Default-Archive”, but any custom index can be used, 
too. 

• Now click on Archive -> Advanced Options -> Manage Indexes and locate the archive index 
you have identified in the step above. Select it and choose “Fields…” from the action gear at 
the bottom of the screen. 

• This will open a screen like this: 

!  

• You can set up custom fields here, which will automatically show up in the “Add metadata” 
window during archive processes if inside the P5 Archive App settings you have chosen to add 
metadata. 

• To store metadata transferred from FCPX, we use a script to create all fields we currently know. 
If you want to store less metadata than known by FCPX, you can safely delete the metadata 
fields you don’t need. 

• On the P5 Archive server, run the script “create_md_fields.py” by opening a Terminal window 
and typing: 
sudo ./create_md_fields.py Default-Archive

• The “sudo” part means that the following command will run with superuser permissions, 
“create_md_fields.py” is the name of our script. The “./“ part on the left of the script name is 
necessary if the script sits in your current working directory. “Default-Archive” is the name of 
the archive index you have identified above. Please replace this string with the name of the 
archive index you want to use with your archive plan. 

• Once you run the command above, it will ask you for your admin password and then 
automatically create all metadata fields listed inside the script as  md_fields = 
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{'com.apple.proapps.custom.archive': ‘Archive', … 

• On the left hand side inside this dictionary, the Final Cut Pro X key of a metadata field is listed, 
on the right hand side of the colon you find the display name of the field. You find the metadata 
fields used in your Final Cut Pro X library by exporting a 1.5 XML file and looking at the “md” 
keys. You can add any custom keys you create inside FCPX to the md_fields dictionary before 
you run it and let the script create the fields in your P5 Archive index. 

• Please note, that for the archive export, the “Extended” metadata view will be used. Make sure 
all your metadata fields are enabled inside this metadata view. 

Important Note: The create_md_fields.py script requires Python 2.7 or later to be installed on the 
P5 system and runs on Linux or OS X. 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3. Change Log 
• Version 1.1.1, release date 21.11.2016: 

◦ fixed a bug, which randomly made the P5 Archive App crash when opening a preview 
for a p5a file 

◦ when triggering an archive or restore process or when opening a p5a file while the P5 
Archive App has not been started, yet, properly queues the event so that it will be 
processed during startup of the app 

◦ video previews will be played in the QuickTime Player 

◦ when the app starts up and the previously configured server can not be reached, the 
app starts up properly. now 

• Version 1.1, release date 08.08.2016: 

◦ added archiving from within Final Cut Pro X via Share Destination 
• Version 1.0, release date 24.11.2015: 

◦ initial release
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